On our Legacy versions of the Mindifi iOS apps, you may see the following warning:

“The developer of this app needs to update it to improve its compatibility.”

Our recent updates to our suite of iOS apps fixes this issue. If you are still seeing this issue please update the app from the App Store.